Error uploading service extension (make imagex_push)

After I got the extend-helper-cli authorization token cached (see “401 error” post), I ran the upload again using the following command:

make imagex_push IMAGE_TAG=v0.0.1

It seemed to run well for a while, but then there was an error while it was running apt-get install:

=> ERROR [linux/arm64 stage-2 2/11] RUN apt-get update && apt-get install -y supervisor procps --no-install-recommends && rm -rf /var/lib/apt/lists/*

Here’s where the specific error seems to be:

77.52 Setting up supervisor (4.2.2-2) ...
84.23 invoke-rc.d: could not determine current runlevel
84.36 invoke-rc.d: policy-rc.d denied execution of start.
86.72 Processing triggers for libc-bin (2.31-13+deb11u3) ...
86.78 qemu: uncaught target signal 11 (Segmentation fault) - core dumped
86.78 Segmentation fault
86.79 qemu: uncaught target signal 11 (Segmentation fault) - core dumped
86.79 Segmentation fault
86.80 dpkg: error processing package libc-bin (--configure):
86.80  installed libc-bin package post-installation script subprocess returned error exit status 139

Any ideas/suggestions?


Hi Chris,
The team will take a look at this soon.

Hi Chris,

By chance, are you affected by the recent (and still ongoing) docker mac issue? Apparently, one of the easiest workaround for now is to downgrade the docker to 4.26.1.

As for the extend-service-extension-csharp sample app itself, our tests currently does not detect this issue. So, we double check by trying to reproduce the issue manually with the following steps and still unable to get the issue.

git clone
cd extend-service-extension-csharp
make imagex



Hi, this is on Windows running in a git bash shell in VS Code, not on a mac.

I made sure to fetch latest on the sample. I got the same error running make imagex and make imagex_push with extend-service-extension-csharp:

101.7 Setting up supervisor (4.2.2-2) ...
108.2 invoke-rc.d: could not determine current runlevel

I’ve tried both git bash and WSL with the same results. I’ve tried sudo make imagex. I’ve tried manually exporting a RUNLEVEL variable. Nothing has worked. Research online hasn’t led to any ideas.

I’m currently blocked on this and another error running Unity codegen.

Thanks, Chris

Hi @chrislambertus,

Do you still need help regarding this?



Nope, it’s working now.

For the record, we didn’t find the problem and a fix for it, per se. But we did work around it…

The problem seemed to be some “flakiness between Docker Desktop and WSL”, to use the scientific terminology. Instead of relying on Docker Desktop, we uninstalled it entirely and installed the docker CLI in WSL using these steps. You have to change any docker-compose statements to docker compose but otherwise it Just Worked :tm:. Also, any docker commands have to be made in WSL from then on.

Cheers, Chris