Persistent Deployment Failed on service extension in both dev and prod

Hi folks,

Our project was previously using the Starter dev environment (ie, AccelByte migrated our data from dev to prod in early April. We’ve still been uploading our service extension and running against dev since then. I ran into an issue trying to update environment variables and restart our dev service extension today: after being in Starting... mode for a while, it then switched to Deployment Failed and wasn’t running.

Since we’d been told dev was going away soon, we then started using our migrated data and services on the prod environment. The service extension there was running, but a month out of date. I changed everything to point to the new environment and uploaded a new image, but it also gave Deployment Failed. I tried several times and even downgrading to the previous image, but it was the same thing each time.

What I did so far: I’ve got my image built, set up the base URL, client ID and secret, made sure the namespace was correct, and this way I’m able to get an AB auth token and successfully upload an image. It looks like we have the basics right.

My team is blocked on testing and iterating this service extension now, and we can’t go back to dev due to the same error message.

Any ideas?

Thanks, Chris

Hi Chris,

We have reviewed your Service Extension app and noticed that you added an environment variable with a value of the integer/number data type. We have confirmed that the Extend system cannot parse the integer/number data type as expected, which is causing the issue you’re facing. Rest assured, we will address this in a future release.

As a workaround, please wrap the environment variable value with single quotes, for example, ‘2’, and then click the ‘Restart and Apply’ button.

Please let us know if the workaround resolves the issue for you


I tried this workaround but it failed in a new way, at least with my 2-digit numeric value (15 in this case). Single quotes wouldn’t work for that (though I did try anyway for completeness sake) so I tried double quotes and got an immediate error saying “Sorry, the service is temporarily down”. I removed the env variables again and it worked.

Cheers, Chris

Thanks for confirming, Chris.

It seems there are steps required to be done on our side before you’re able to use the workaround. The team will keep you updated.

Meanwhile, is it possible you use other values than integer, e.g. string? @chrislambertus Thinking a way so you’re not blocked.

1 Like

For now I’ve just defaulted those values in the service extension to the ones I wanted to set. I’m not blocked anymore.

Thanks, Chris

Got it. We will keep you updated about the issue you experience with the workaround.

1 Like

Hi @chrislambertus

  1. Since you’re unblocked, we will focus on fixing the issue instead of working on the workaround. We target to deliver the patch to AGS Starter next week. The timeline is subject to change. I’ll keep you updated.
  2. To avoid the deployment failed issue, please avoid using integers for your environment variable until we patch the issue.

Hi @chrislambertus ,
The team delivered a patch yesterday on Once you’re available, can you try again?

Hi @chrislambertus ,
In case you miss the notification.

Thanks Vincent, I saw that it came by but I’m not in a position to try it quite yet – I have major local changes and in order to test this, I have to catch it running in Unity in dev (which is broken at the moment, another post incoming). I’ve left a big fat TODO at the top of my list so that once I’m building and deploying again I can give it a shot!

Thanks, Chris

1 Like

Thanks for the update @chrislambertus Looking forward to your test result.