AGS Starter DS Problem

I have a problem with requesting DS. When I first created the fleet, Session requests for DS were normal, but after a while, requests for DS were easy to fail. And when I create multiple DS caches in the fleet, requests for DS are more likely to fail.

There is also the question of whether the VM configuration is too low:

@user13 Can you check how many number of server running on 1 VM instance? the default VM instance (ttx1.s) cpu only have 2 cores and 2GB of ram.
It should be in Fleet Manager → your fleet name → configure tab → DS Host → Number of server. Try to set it to 1.

If you can get us the log as well would be nice. From the history tab, click action ‘view’, Grab the dsid

then go to logs and artifacts, then search by dsid.

ds_01902a58-e2f7-7621-bae4-0022d01986b5.log (4.9 KB)
Now I cannot search the DS log in the fleet, I can only give you the latest one in the log

When I set up a DS, the first Session can request DS, but I have a different attribute of the Session needs to request DS, this time there is a problem

The log does cut off even before the AGS SDK initializes. It’s not that useful.

When I set up a DS, the first Session can request DS, but I have a different attribute of the Session needs to request DS, this time there is a problem

Can you elaborate more about the attributes that you mention here?

These attributes are different. So I feel like setting up a DS is not enough.

Hi @user13,
Looking at the log you provided, we are still unable to investigate it further due to the log quality. We have a few suggestions that you can try to help us investigate:

  1. Try using LocalDS with AMSSim to debug locally before uploading it to AMS. This will ensure that the process of registering the DS to AMS is correctly implemented. More details on AMSSim: Integrate your dedicated server to AMS using the AGS SDK | AccelByte Documentation
  2. As Afif mentioned, try upgrading the VM type, as the crash occurred at the beginning and the DS is unable to reach the ready state, it’s possible that the current VM can’t accommodate your DS.

Hello, I have debugged it locally before uploading, it is OK.

Hi @user13,

One of the reasons Failed to request occurs is that there is no available DS in the AMS. Here are our suggestions:

  1. Increase the Max DS: Try setting the max DS to more than 1. You can do this by navigating to Fleet Manager → your fleet name → Configure tab → Region → Set the Max Servers to a value greater than 1.
  2. Implement the Shutdown Mechanism: If the DS is already claimed and no player is connected to it, you can start shutting down the DS. Here are examples of how we do it in ByteWars:
  1. Adjust the Session Timeout: Set the session timeout according to the match duration. For example, if a match typically lasts 5 minutes, set the session timeout to 300 seconds (5 minutes). Read more about session timeout on step #6.

Thank you very much, adding the DS closure is very helpful!
But I still have multiple DS issues: I have problems caching multiple DS instances in a fleet, I set up a cache for 4 instances, but it only prepares 2, and sometimes all instances are emptied.

Hi @user13,

Can you make sure to set the number of servers running on a single VM to 2? As Afif mentioned, the default VM instance (ttx1.s) has only 2 CPU cores and 2GB of RAM. You can set this in Fleet Manager → your fleet name → Configure tab → DS Host → Number of Servers. Try to set it to 2.
Since ttx1.s purpose is only for testing, please don’t force it to run many DS into single VM.

As for reference, Byte wars development server consume UpTo 400MB to 600MB of ram, when on gameplay it also can take about 70-80 percent of CPU peak, so using TTX1.s we only use 2 servers per VM instance.

OK ,Thank you very much !